Finalize the names of all kernel object types.
- Rename "event" to "alert".
- Justification: Avoids confusion with the "unrelated kernel event logger". Don't want to rename object to "signal", since the object does have some significant operational differences from POSIX signals. "Alert" conveys the idea that something has happened that requires attention, without making any claim about the significance of the occurrence. (i.e. You can have both major disaster alerts, and also minor alerts that aren't a big deal.)
- Rename "memory map" to "memory slab".
- Justification: Look up "slab allocation" in Wikipedia and you'll see it fits this object pretty well. That is, the object uses a set of preallocated chunks of a specific size to achieve efficient allocation and deallocation while avoiding fragmentation.
- Note: The object actually uses a SLUB-type allocator (rather than a SLAB allocator), since it only has a single linked list of unallocated chunks. However, this is an implementation detail that we could conceivably change in the future (although it's unlikely). Calling the object a "memory slub" would just confuse users ...
- Leave "memory pool" naming alone.
- Justification: Look up "memory pool" in Wikipedia and you'll see the name is only a so-so fit for this object (i.e. some aspects apply to the object, while others don't). However, there doesn't seem to be another name for the object that more accurately reflects what it does. The object uses a technique called "buddy blocks" or "buddy memory allocation", but calling the object a "memory buddy" would just confuse users ...
IMPORTANT: Should propose the new names to the Zephyr community to get their buy in before making any changes.
[further thinking] From this link: https://en.wikipedia.org/wiki/Memory_management#Implementations, maybe rename 'memory maps' to 'memory pools' and 'memory pools' to 'buddy allocators' ?