Uploaded image for project: 'Zephyr'
  1. Zephyr
  2. ZEP-546

UART interrupts not triggered on ARC

    Details

    • Type: Story
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.6.0
    • Labels:
    • Environment:
      Zephyr commit Id: ca57a7816d69928a3be25072b691ceb0fe96ba16
      Bluetooth: L2CAP: Start servicing configuration request from remote

      Description

      Configuration
      ==========
      <Arch> ARC
      <Board>quark se devboard
      <Kernel> nano
      Bug detailed description
      UART sample application does not receive interrupts when it is running on ARC core.

      Steps to reproduce:
      1) Start with the UART application available in zephyr/samples/drivers/UART. Add the following to prj.conf
      CONFIG_UART_QMSI=y
      CONFIG_UART_INTERRUPT_DRIVEN=y

      2) Build the UART application for ARC as "make BOARD=quark_se_sss_devboard"
      3) Flash the application

      When the application starts running we see the poll mode works however the interrupt mode does not work. The same application works in interrupt mode when run on x86.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                ajross71 Andy Ross
                Reporter:
                raveeh ravi hegde
              • Votes:
                0 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: